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“We are often inferested in understanding the way that Y is

affected as X1, ..., Xp change. In this situation we wish to
estimate f, but our goal is not necessarily to make predictions
forY . We instead want to understand the relationship between
X and Y , or more specifically, 1o understand how Y changes as
a function of X1, .. ..Xp. Now fcannot be treated as a black
box, because we need to know its exact form.”

Excerpts from pages 19-20, An Introduction to Statistical Learning, James, et al (Springer)
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morke’nng campaign.

, based on observations of
demographic variables measured on each individual. In this
case, the demographic variables serve as predictors, and
response to the marketing campaign (either positive or negative)
serves as the outcome. The company is not interested in
obtaining a deep understanding of the relationships between
each individual predictor and the response;

This is an example of modeling for

L] L] ’ ’
D re d I CTI O n . Excerpts from pages 19-20, An Introduction to Statistical Learning, James, et al (Springer)
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e Whatis it?

e What can it do¢ (use cases)

« How does it work?

« JIMP Mechanics
e Interpret results (statistically)
 Interpret results (operationally)
e How to iImplement the results
« How to understand the managerial
implications
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WHAT IS IT?




quantitative response variable (Y) with a single predictor

variable (X).
Y | X | Objective | Summary of | Statistical | Operational
Fit Significance Significance
Measures Measure

Continuous Confinuous or  Explanatory RSquare Adj, Prob>F Mean and
Categorical Root Mean (p-value) Individual
Square Error Confidence
Limits &
Variable ClI
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WHAT CAN IT DO< (USE CASES)




Is there a relationship between advertising budget and
salese

Is there a relationship between sales and price?

Which media contribute to salese

Which media conftribute the most to salese
Understanding housing prices

Simple Linear Regression | Jim Grayson, PhD



Simple Linear Regression | Jim Grayson, PhD 10

HOW DOES IT WORK?




Figure 3.1, An Introduction to Statistical Learning by James, et al, (Springer 2013)
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Least Squares
Regression:

Fit line to minimize
the sum of
squared residuals
e?+el+. ... te?
where e =y -V

Our model is:
y=Bo+B1+ ¢

We estimate the
B’'s by finding a
regression line

y =y + b,x




Figure 10.1 51‘1;-111'-1_1-1191_.&&51 Squares Regression

b, is the slope
& Parameter

The equation for the line of fitis

M"-._x
-"ﬁ'\-\.
-‘lﬁ'\-\.
a l-l"\-\.

}I
' J/ ThIS difference is called a
’ P ‘ ™ residual. The sum of squares

of the residuals is minimized.

- by is the intercept parameter

Figure 10.1, JMP Start Statistics, 4e by Sall, et al, (SAS 2012)
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JMP MECHANICS




Simple linear regression is used to model the relationship between two continuous variables.

,.——-_'——_7

Simple Linear Regression Using Fit Y by X

1. F

2. Click on a continuous variable from 5 -

C
3.5

Click OK to cenerate a scatterplot.

rom an open JMP’ data table, select{Analyze > Fit Y by X.

lick ¥, Response (continuous variables have blue triangles).

elect a second continuous variable, and click X, Factor.

5.| To fit a regression ling, click on the red triangle and select

F

it Line.

By default, IMP will provide the following results:

The regression equation (under Linear Fit).
The Summary of Fit.
Lack of Fit (if the data table includes replicates of X

values).
The ANOVA table.

The parameter estimates.
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*x Big Class - Fit Y by X of weight by height - JMP Pro (][ .S -

e

| File Edit Tables Rows Cols DOE Analyze Graph Tools | Make @ SCGHerplOT fo dlsploy thes
Q) et Viewe 3 Wiiow i el relationship between two
JREH @ (e OsPA+

quantitative variables

01/26/2015 12:49 PM

| ]
Data Table=Big Class,Locked File=C:\Program From red trlangle select Fit Line:
FilarSAQ\JMPPRO\11\Samples\Data\Big Class.jmp
] ] . . " i i i i
@ - = Fit of weight By height | ~ Bivariate kit of weiaht By
180 v' Show Points i
: Fit Mean
160 ‘ Example: Big Oass.jmp (Help = 5ample Data)
. : :
140 ® Fit Polynomial
" . .. Fit Special...
2 120 . . Fit Spline
= H * LN ] . ®
* e ° Kernel Smoother
100 .o " Fit Each Value
L ] L
20| o LI ® . Fit Orthogonal
* Density Ellipse
.
60 * Nonpar Density
50 55 60 65 70 .
height Fit Robust
| > B4 v
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SN N

=~ Bivariate Fit of weight By height
180

160
140

120

welght

100

a0

60

MNotes: Simple linear regression can also be performed from Analyze > Fit Model. For more details on regression

analysis, see the book Basic Analysis (under Help > Books) or search for “regression” in the JMP Help.
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bl Linear Fit

& 4 Linear Fit
weight = -127.1452 + 3.7113549*height
4 Summary of Fit

ESquare 0.502917 .
Hsﬂuaremj 0.480836 Parameter Estimates

Root Mean Square Error 15.8578A Term Estimate 5td Error t Ratio Prob>|t]
sl ol o 105 Intercept -1271452 37.52372 -339  0.0016*
Observations (or sum Wats) L height 37113540 0598550 620  <.0001*
Lack Of Fit

4 Analysis of Variance

Sum of
Source DF  S5guares Mean Square  F Ratio
Maodel 1  9668.079 9665808  38.4460
Error 38 9555921 25147 Prob>F
. Total 39 19224000 =<.0001*
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| inear Fit

Lir'|r-_- l:lf Flt
Confid Curves Fit
Confid Curves Indiv

Line Color

Line Style

Line Width

Report

Save Predicteds
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Indiv Confidence Limit Formula
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MODEL STATISTICAL VALIDITY




B—
20 I

ASS UMPTIONS FOR INFERENCE
ABOUT REGRESSION COEFFICIENTS

L—1—E—N




. N

SR SSUMPTIONS FOR INFERENCE  *

e Linearity Assumption L—-I—-E—N
o Scatterplot of y vs. X

o Scatterplot of residuals plotted against predicted values

Residual by Predicted Plot

40

30

20 o

lO @ ° L ]

f—hsuag vanus o '....-..n.....'.-‘._....? ..........

weight Residual

-10 ” P o, °
_20 e © ..

-30
90 100 110 120 130 140
weight Predicted

Chapter 15, Business Statistics 3e by Sharpe, De Veaux and Velleman (Pearson)
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ABOUT REGRESSION COEFFICIENTS
L-1—E-N

e Independence Assumption (Linearity Condition)
e Plausible if collected with appropriate randomization

Chapter 15, Business Statistics 3e by Sharpe, De Veaux and Velleman (Pearson)

Simple Linear Regression | Jim Grayson, PhD



PTIONS FOR INFERENCE &g
REGRESSION COEFFICIENTS

L—1—E—N

e Equal Variance Assumptions (Equal Spread Condition)
o Scatterplot of the residuals vs predicted values

Residual by Predicted Plot

40
30
20
10
0
-10
-20
-30

weight Residual

90 100 110 120
weight Predicted

Chapter 15, Business Statistics 3e by Sharpe, De Veaux and Velleman (Pearson
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 Normal Probability Assumptions (Nearly Normal Condition)
« Histogram or Normal Probability Plot of residuals

Residual Normal Quantile Plot

Simple Lin

weight Residual

Chapter
ar Regre

40
30
20
10

0

-30

Normal Quantile

ss Statistics 3e by Sharpe, De Veaux an

n | Jim Grayson, PhD
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Linear Fit

4 ¥ LineofFit
Confid Curves Fit
Confid CurvesIndiv~ [PEEG
Line Color
Line Style
Line Width

v Report

Save Predicteds
Save Residuals

Mean Confidence Limit Formula

Indiy Confidence Limit Formula
Plot Residuals 30 : ® o0
Set a Level 20 ° : o

Confid Shaded Fit
Confid Shaded Indiv

Remove Fit

weight Residual
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. weight Predicted

120
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Actual by Predicted Plot
180
160

weight Actual

Residual by Row Plot
40
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Row Number
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Residual by X Plot
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INTERPRET RESULTS (STATISTICALLY)




I I ————
- Linear Fit -

AlinearFit 00 - 29
B weight = -127.1452 + 3.7113549%height
4 Summary of Fit The Rsquare / Rsquare Adj gives us a
e A o measure of the variability in the data
P NG explained with our model. Larger values are
Observations (or Sum Wats) preferred.
Lack Of Fit
ﬂ‘“‘"a'“‘“’f""ﬂ”:fﬂ The Root Mean Square Error tells us the
T R T e stfandard deviation of the error (€) — @
el ' cosure of variability of the model. We
C.Total 39 19224000 <.0001* might multiply this by 3 to give us some
insight info the variability range of roughly
+ 48.
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x Linear Fit

o < Linear Fit

& weight = -127.1452 + 3.7113540%height

] < Summary of Fit
Rsquare 0.502917
RSquare Adj 0.489836
Foot Mean Square Error 1585786
Mean of Response 105
Observations (or Sum Wygts) 40

Lack Of Fit

4 Analysis of Variance

Sum of
Source DF Sguares Mean Square
Maodel 1 9668.079 966808
Error 38 9555921
. Total 3919224000 = 0001~
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Regression model is that at least one of the

L —————— B
senerally the alternate hypothesis for @ . T=

parameters is significant (not equal to 0). In
simple linear regression there is only one
predictor parameter, so the null for this case is
that the B, (height) = 0, which would imply that
there is no slope and that a horizontal line at
the mean weight would describe the
association between height and weight.

With a p-value (Prob > F) of less than 0.0001 we
can reject the Ho and accept Ha that the
model parameter (height) has a slope (is not
flat) - we are accepting Ha that 3, # 0.




. Parameter Estimates
= Term Estimate Std Error
[l Intercept -127.1452 37.52372
height  3.7113549 0.598558

This is somewhat redundant for one
predictor, but having rejected the null
and accepted the alternate we then
look at the p-value of each parameter
to determine if it is significant. For height
in our example this confirms that b, # 0

because the p-value (Prob >|1]) is
<0.0001
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lLinear Fit

- —— REPRIC IV _,_....------oﬁﬁdé_nce Limit and Individual
Y edonere B Confidence Limit provide a better understanding

-

Confid Curves Indiv of prediction variability
t::: Z:lzr Bivariate Fit of weight By height
Line Width 180

v FReport

160

Save Predicteds

Save Resid

140 *

Mean Confidence Limit Formula

Indiv Confidence Limit Formula

120

Residuals

Set a Level
100

Confid Shaded Fit
Confid Shaded Indiv
80

Remove Fit

60
50

Linear Fit
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e

Parameter Estimat

Term Estimate 5td Error t Ratio Prob:= |t]

Intercept -1271452 37.52372
height  3.7113549 0.598559

Select the “parameter’

Select Columns >

-3.39  0.0016%

T e e
E:I ILIII-I ;-.' III-I II-I II-I1 .

Select Lower 95% and Upper 95%
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¥ Column...

Make into Data Table

' table and right click > |

v

Term

~Bias

* Estimate

* 5td Error

* tRatio

* Prob>|t|

Lower 95%

Upper95%

5td Beta
VIF
Design 5td Error




_ Parameter Estimates
& Term Estimate 5td Error tRatio Prob>|t|] Lower953% Upper953%
Intercept -1271452 3752372 -3.39  0.0016% -203.108  -51.18245
height 37113549 (0.598550 6.20 <0001 24996359 49230739

The Lower 95% and Upper 25% are confidence intervals around
the coefficients.

Our coefficient of interest is height. The height coefficient was

determined with sample data; therefore, there is uncertainty in
the “true” height coefficient. We can interpret the confidence
interval values to mean we are 95% confidence the true height
coefficient is in the interval (2.5, 4.9).
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HOW TO IMPLEMENT THE RESULTS




IPPI e Tesutis-Py-prov rding a value for X (height) and then
using the simple e@r regreSS|on formula to compute Y
(pre|c’red We|gh’r) and other measures such as confidence

B— infervals

Predicted Lower93% Upper93% Llower95%  Upper 9%
age  sex height weight weight  Meanweight Meanweight Indiv weight Indiv weight

«\140.07230375 ) 127 54697353 15259763396 1056127961 17453181139

-127.14524861092
+/3.71135489385956 * height

2.02439416391197

Vec Quadratic
[5.59915942441948 -0.0891152585838446,

'12?145 248 6'1 D'EIE s -0.0891152585838446 0.00142470437384244]
+(3./1135489385956 * height Ll etght

*251.471592144628
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HOW TO UNDERSTAND THE MANAGERIAL
IMPLICATIONS, OR THE




We developed the explanatory model to help us “explain” and
understand the relationship between height and weight. What did we
learne

« There is a positive linear relationship between height and weight

 Our model explains about 50% of the variability in the data — maybe
there are other factors that might help us explain our data

* The height coefficient (3.7) tells us for every additional inch in height,
there is on average, an additional 3.7 pounds in weight
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e For a person thatis 72 inches tall the 95% mean confidence interval is
(128, 153) — we think about whether this variability is acceptable for
providing understanding about the height — weight association.
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